Your server is running PHP version 4.3.9 but WordPress 3.2.1 requires at least 5.2.4.